[cmucl-help] Building on OSX

Didier Verna didier at lrde.epita.fr
Tue Jan 23 15:19:05 UTC 2018


I have an installation of CMUCL 21c on my Mac from the downloaded
darwin-x86 tarballs. It seems however that I cannot inspect values with
Slime. My guess is this is because the tarballs don't provide the
source code, or at least enough information for the inspector to
work. Is this correct?

If so, I need some help building from the source. I cloned the repo and
tried the simple build process, but it fails with the error below. I
tried hacking src/bootfiles/21c/boot-21c-cross-x86.lisp to undo the
:random-mt19937 -> :random-xoroshiro stuff, but it fails in the same
way. I don't understand the build process of CMUCL.


File-error in function TRUENAME:
   The file "target:code/rand-xoroshiro.sse2f" does not exist.
   [Condition of type SIMPLE-FILE-ERROR]

  0: [CONTINUE] Return NIL from load of "target:tools/worldbuild".
  1: [ABORT   ] Return to Top-Level.

Debug  (type H for help)

(TRUENAME #P"target:code/rand-xoroshiro.sse2f")
; File: target:code/filesys.lisp

; File has been modified since compilation:
;   target:code/filesys.lisp
; Using form offset instead of character position.
       :FORMAT-CONTROL (GETTEXT "The file ~S does not exist.")

Resistance is futile. You will be jazzimilated.

Lisp, Jazz, Aïkido: http://www.didierverna.info

More information about the cmucl-help mailing list