[cmucl-help] Building on OSX

Raymond Toy toy.raymond at gmail.com
Tue Jan 23 15:47:32 UTC 2018

>>>>> "dvl" == Didier Verna <didier at lrde.epita.fr> writes:

    dvl> Hello,

    dvl> I have an installation of CMUCL 21c on my Mac from the downloaded
    dvl> darwin-x86 tarballs. It seems however that I cannot inspect values with
    dvl> Slime. My guess is this is because the tarballs don't provide the
    dvl> source code, or at least enough information for the inspector to
    dvl> work. Is this correct?

Slime works for me.  Can you give a short example?

Did you download the src tarball?  And setup the path to the source

    dvl> If so, I need some help building from the source. I cloned the repo and
    dvl> tried the simple build process, but it fails with the error below. I
    dvl> tried hacking src/bootfiles/21c/boot-21c-cross-x86.lisp to undo the
    dvl> :random-mt19937 -> :random-xoroshiro stuff, but it fails in the same
    dvl> way. I don't understand the build process of CMUCL.

Hmm.  I should have tried this out, but didn't, since I kind of
expected everyone to use the new xoroshiro128+ generator.  I'll try to
fix this up, but in the mean time, you have to do a cross-compile:

bin/create-target.sh xtarget x86_darwin
bin/create-target.sh xcross x86_darwin
bin/cross-build-world.sh -crl xtarget xcross src/bootfiles/21c/boot-21c-cross.lisp <21c-lisp>
bin/build.sh -C "" -o xtarget/lisp/lisp

This should give you a full working lisp.

Or even simpler, grab the 2018-01 tarballs and do a normal build:

bin/build.sh -C "" -o <2018-01/bin/lisp>


More information about the cmucl-help mailing list